You may receive a Dr. Watson access violation error message when you query a mobile phone that you use as a modem in Windows 2000 (837047)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Consider the following scenario. You use a Bluetooth connection or an infrared connection to connect a mobile phone to a computer that is running Microsoft Windows 2000. You use the mobile phone as a modem. In this scenario, when you query the mobile phone by using the Query Modem feature of the Phone and Modem Options Control Panel item, you may receive a Dr. Watson access violation error message.

CAUSE

This problem occurs when the mobile phone returns more than 256 bytes in response to the ATi4 command and to the ATi5 command.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Modemui.dll5.0.2195.690199,08825-Feb-200402:15x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To use the Query Modem feature of the Phone and Modem Options Control Panel item, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Phone and Modem Options.
  3. Click the Modems tab, and then double-click a modem in the list.
  4. Click the Diagnostics tab, and then click Query Modem.
For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/26/2006
Keywords:kbBug kbfix kbQFE kbWin2000preSP5fix kbhotfixserver kbpubtypekc KB837047 kbAudITPRO kbAudEndUser