Clients may not be able to use an 802.1x connection to connect to a Windows 2000-based server that is running IAS with RADIUS authentication (837020)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

You may experience slow or unsuccessful authentication when you try to make a wireless 802.1x connection to a Microsoft Windows 2000 Server-based server. In this scenario, the Windows 2000-based server is running Windows 2000 Internet Authentication Service (IAS) with Remote Authentication Dial-In User Service (RADIUS) authentication.

If you perform a Network Monitor trace, you may find that the Access Point restarts the authentication process by sending a new Identity frame before the original authentication attempt is completed.

CAUSE

This problem may occur because the computer that is running Windows 2000 IAS may send the Microsoft Point-to-Point Encryption Protocol (MPPE) send key and receive key with the Access-Challenge packet instead of with the Access-Accept packet. For more details, see Request for Comments (RFC) 2548, section 2.4.1. To locate RFC 2548, see the "References" section.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   01-Jul-2004  21:56  5.0.2195.6944     101,136  Rastls.dll   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about RFC 2548, visit the following Internet Engineering Task Force (IETF) Web site:

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB837020 kbAudITPRO