No updates appear when you scan for updates on the Windows Update Web site (836973)



The information in this article applies to:

  • Microsoft Windows Update, when used with:
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98

SYMPTOMS

When you click Scan for Updates on the Windows Update Web site, the Windows Update is looking for available updates progress bar does not change from 0%, and no updates appear.

CAUSE

This issue may occur if a Secure Sockets Layer (SSL) connection cannot be established with the server or an error occurred during the Windows Update scan for updates.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Install the latest scripting engine

To install the latest scripting engine, visit the following Microsoft Web site:

Method 2: Repair Internet Explorer

To repair Internet Explorer, use the method for your operating system and your version of Internet Explorer.

Windows 98, Windows 98 Second Edition, or Windows Millennium Edition with Internet Explorer 5.0 or 5.5

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Change or Remove Programs tab, click Microsoft Internet Explorer.
  4. Click Change/Remove, click Repair Internet Explorer, and then click OK.
  5. When you are prompted to detect and repair problems with Internet Explorer, click Yes.
  6. If you are prompted to restart the computer, click Yes to restart the computer.

Windows 98, Windows 98 Second Edition, or Windows Millennium Edition with Internet Explorer 6 or with Internet Explorer 6 SP1

  1. Connect to the Internet.
  2. To download Internet Explorer 6 SP1, visit the following Microsoft Web site, and then click Download Now:
  3. Follow the instructions to download and install Internet Explorer 6 SP1.

    Note If you receive a message that says that the installation cannot continue because a later version of Internet Explorer is already installed, contact the manufacturer of your computer for help with the reinstallation of Internet Explorer.

Method 3: Turn off or remove Internet acceleration software or Web monitoring software

Temporarily turn off or remove any Internet acceleration software or Web monitoring software when you use the Windows Update Web site. Make sure that you turn on the software again after the update is completed.

Method 4: Disable the automatic configuration script

To disable the automatic configuration script, follow these steps:
  1. Open Internet Explorer, and then click Internet Options on the Tools menu.
  2. On the Connections tab, click LAN Settings.
  3. Clear the Use automatic configuration script check box.
  4. Click OK two times.

Method 5: Register your system files

To register your system files, follow these steps:
  1. Click Start, click Run, and then type regsvr32 c:\windows\system\vbscript.dll in the Open box.
  2. Click OK.
  3. When you receive the "DllRegisterServer in vbscript.dll succeeded" message, click OK, and then try to use the Windows Update Web site.
  4. If the issue still occurs, repeat steps 1-3 for each of the following commands:
    • regsvr32 c:\windows\system\mshtml.dll
    • regsvr32 c:\windows\system\msjava.dll
    • regsvr32 c:\windows\system\jscript.dll
    • regsvr32 c:\windows\system\msxml.dll
    • regsvr32 c:\windows\system\actxprxy.dll
    • regsvr32 c:\windows\system\shdocvw.dll

Modification Type:MajorLast Reviewed:12/14/2005
Keywords:kbwindowsupdate kbprb KB836973 kbAudEndUser kbAudITPRO