SYMPTOMS
When you use Microsoft Outlook to set the permissions of a
public folder in a Microsoft Exchange Server 2003 mailbox, you receive an error
message that is similar to the following:
The modified
permissions cannot be saved. The client operation failed.
When you use
Exchange System Manager to set the permissions of a public folder in an
Exchange 2003 mailbox, you receive an error message that is similar to the
following:
Invalid Windows handle. ID no.
80040102
CAUSE
This problem may occur if the following conditions are true:
- You changed the access control lists (ACLs) by using
PFDavAdmin, RewriteACL, or another program that uses XML to write permissions
to public folders.
- You added the role of Reviewer to the public
folders.
If you use XML to write permissions to public folders, the ACLs
may become out of canonical order. This problem may occur although the XML is
correctly formatted. Additionally, this problem occurs when the following
contexts have the same access mask and are written and evaluated at the same
time:
- Effective
- Container
- Subitem
These three contexts have the same access mask when an
individual user account has its permissions set as Reviewer.
RESOLUTION
Cumulative update information
To resolve this problem, install Microsoft Exchange Server 2003
Service Pack 1 (SP1).
For
more information about Exchange 2003 SP1, click the following article number to
view the article in the Microsoft Knowledge Base:
836993
How to obtain the latest service packs for Exchange Server 2003
Hotfix information
Alternatively,
apply the following hotfix to resolve this problem. A supported hotfix is now available from
Microsoft, but it is only intended to correct the problem that is described in
this article. Only apply it to systems that are experiencing this specific
problem. This hotfix may receive additional testing. Therefore, if you are not
severely affected by this problem, we recommend that you wait for the next
Microsoft Exchange Server 2003 service pack that contains this
hotfix.
To resolve this problem immediately, contact Microsoft Product
Support Services to obtain the hotfix. For a complete list of Microsoft Product
Support Services telephone numbers and information about support costs, visit
the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for
support calls may be canceled if a Microsoft Support Professional determines
that a specific update will resolve your problem. The usual support costs will
apply to additional support questions and issues that do not qualify for the
specific update in question.
File information
The English version of this hotfix has the file
attributes (or later file attributes) that are listed in the following table.
The dates and times for these files are listed in Coordinated Universal Time
(UTC). When you view the file information, it is converted to local time. To
find the difference between UTC and local time, use the
Time
Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------------
26-Feb-2004 12:19 6.5.6980.72 373,248 Exsmtp.dll
26-Feb-2004 10:20 6.5.6980.72 49,152 Mdbevent.dll
26-Feb-2004 11:00 6.5.6980.72 3,190,272 Mdbmsg.dll
26-Feb-2004 10:22 6.5.6980.72 24,064 Mdbrole.dll
26-Feb-2004 11:48 6.5.6980.72 13,312 Mdbtask.dll
26-Feb-2004 11:45 6.5.6980.72 5,045,760 Store.exe