Logon failure events are incorrectly recorded for trusted MIT Kerberos realm users (836878)



The information in this article applies to:

  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP Professional

SYMPTOMS

When users log on to their user accounts that are from a trusted MIT Kerberos realm, a logon failure event is incorrectly recorded in the security event log of the domain controller. Additionally, if an account lockout policy is enabled, these user accounts may become locked out. However, the users do not experience a logon failure when the lockout occurs.

CAUSE

This problem may occur if the Encrypting File System (EFS) is used to help protect files on the local computer. EFS relies on the Data Protection API (DPAPI) to encrypt a user's key by using a master key. Starting in Microsoft Windows XP, the DPAPI tries to back up this master key to the domain controller every time that the user changes the user logon password. Because a service principal name (SPN) is not correctly formed, authentication that uses an account from a trusted MIT Kerberos realm causes a logon failure on the domain controller.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Microsoft Windows XP
   Date         Time   Version           Size     File name
   -----------------------------------------------------------
   05-Apr-2004  21:02  5.1.2600.1513     668,160  Lsasrv.dll       
Microsoft Windows XP 64-Bit Edition
   Date         Time   Version         Size       File name    Platform
   ---------------------------------------------------------------------
   05-Apr-2004  21:06  5.1.2600.1513   2,071,552  Lsasrv.dll   IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB836878