Unidrv.dll print support for JPEG pass-through and PNG pass-through in Windows Server 2003 (836797)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use Joint Photographic Expert Group (JPEG) pass-through or Portable Network Graphics (PNG) pass-through to print on an inkjet print device in Microsoft Windows Server 2003, the Unidrv.dll driver does not function correctly. The Unidrv.dll driver must permit JPEG pass-through or PNG-pass-through to support borderless printing, red-eye reduction, and Exchangeable Image File Format (EXIF) print support.

CAUSE

This problem occurs because the Unidrv.dll driver does not support JPEG pass-through or PNG pass-through. To resolve this problem, you must install this hotfix.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   17-Mar-2004  01:51  0.3.1296.2        264,192  Unidrv.dll       x86
   17-Mar-2004  01:52  0.3.1296.2        795,648  Unidrv.dll       IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbwinservperf kbFilePrintservices kbBug kbfix kbQFE kbWinServ2003preSP1fix KB836797 kbAudOEM