Data is not completely written to files that are located on a network share after you set the attributes of the files in Windows XP Service Pack 1 (SP1) (836767)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

SYMPTOMS

On your Microsoft Windows XP Service Pack 1 (SP1)-based computer, if you use the WriteFile function to write data to a file that is located on a network share, and then you set the attributes of the file by using the SetFileAttributes function, you notice the following symptoms:
  • Not all data is written to the file. The size of the file that is located on the network share is smaller than you expected.
  • You do not receive an error message, and no error messages are logged to the event log.
  • If you perform a Network Monitor trace of the operation, the size of the file is truncated to the same size that is returned to the CreateAndX request in the Windows XP Server Message Block (SMB) packet.
  • You may not be able to open, to rotate, or to view the file on the network share by using the Microsoft Office Document Imaging program.

CAUSE

This problem occurs in situations where SMB incorrectly processes multiple open operations of the file.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbWinXPsp2fix kbQFE kbfix kbbug KB836767 kbAudITPRO