You cannot start the Telnet service on a Windows 2000-based computer (836688)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Datacenter Server SP4
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Server SP4

SYMPTOMS

When you try to start the Telnet service though the net start telnet command line on a Microsoft Windows 2000-based computer, you receive the following error message:
The Telnet service is starting.
The Telnet service could not be started.
The service did not report an error.
More help is available by typing NET HELPMSG 3534.

CAUSE

This problem occurs when you install the hotfix that is provided in the following article on a Microsoft Windows 2000-based computer that has Service Pack 4 installed.

824832 Non-administrator members of TelnetClients groups in any domain in the forest can access a domain controller in any domain

After you install this hotfix, if the Windows 2000-based computer name is six or more characters long, you cannot start the Telnet service.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Feb-2004  00:13  5.0.33670.2       186,640  Tlntsvr.exe      

WORKAROUND

To work around this problem, you must change the computer name so that the name is five or less characters long.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB836688 kbAudITPRO