The number of items that are marked as unread in an Exchange 2003 public folder is incorrect (836686)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

For a Microsoft Exchange 2000 Server version of this article, see 827555.
For a Microsoft Exchange Server 2003 Service Pack 1 version of this article, see 843159.

SYMPTOMS

In Microsoft Exchange Server 2003, when you add a public folder to the Favorites folder in Microsoft Outlook, and then you view the contents of the public folder by using the shortcut that you added to the Favorites folder, you may find that the total number of messages in the folder that are marked as unread is incorrect.

CAUSE

This problem may occur if the public folder that you added to the Favorites folder contains one or more subfolders. Exchange 2003 incorrectly includes subfolders as items when it determines the number of unread items that are contained in a folder.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size     File name
---------------------------------------------------------
02-Mar-2004  11:30  6.5.6980.73    372,736  Exsmtp.dll       
02-Mar-2004  09:35  6.5.6980.73     49,152  Mdbevent.dll     
02-Mar-2004  10:14  6.5.6980.73  3,190,272  Mdbmsg.dll       
02-Mar-2004  09:38  6.5.6980.73     24,064  Mdbrole.dll      
02-Mar-2004  11:03  6.5.6980.73     13,312  Mdbtask.dll      
02-Mar-2004  11:00  6.5.6980.73  5,045,760  Store.exe 

Installation information

This hotfix only prevents the problem from occurring. After you install the hotfix, run the isinteg command with the allfoldertests option on every public folder store in the Exchange organization to fix the problem on existing folders.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301460 Exchange command-line parameters for the Isinteg.exe tool

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the naming schema for Exchange Server software update packages, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbHotfixServer kbQFE kbExchange2003preSP2fix kbQFE kbfix kbBug KB836686 kbAudITPRO