Information Store databases do not mount and you receive an "Operation terminated with error -614" error message when you start a computer that is running Exchange Server 2003 (836611)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

When you start a computer that is running Microsoft Exchange 2003 Server, you may experience all the following symptoms:
  • Exchange 2003 enters recovery mode, and the Microsoft Exchange Information Store service performs a soft recovery.
  • The Microsoft Exchange Information Store service does not start, and the Information Store databases do not mount.
  • You receive the following error message:
    Operation terminated with error -614 (JET_errCheckpointDepthTooDeep, too many outstanding generations between checkpoint and current generation) after 899.914 seconds
  • An event ID error message that is similar to the following is logged to the application event log:
    Type: Error
    Source: MSExchangeIS
    Category: General
    Event ID: 9518
    Description:
    Error 0xfffffd9a starting Storage Group /DC=com/DC=Domain/DC=VE/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=Organization/CN=ADMINISTRATIVE GROUPS/CN=AdministrativeGroup/CN=SERVERS/CN=ServerName/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP on the Microsoft Exchange Information Store. Storage Group - Initialization of Jet failed.

CAUSE

This issue may occur if all the following conditions are true:
  • The log files and the database are shut down correctly. There is no crash to recover from.
  • You rename or delete the E00.chk log checkpoint file.
  • There are more then 1,008 log files between checkpoints to replay on the server.
  • In a "roll-forward" recovery, one or more databases in the storage group are lost, but the log files remain intact on the server at the time of recovery. The "roll-forward" recovery operation is not completed successfully.
In this situation, the Microsoft Exchange Information Store service performs a soft recovery and replays all log files during startup. Because the log files and the database were shut down correctly, there is no recovery to perform. Because there is no checkpoint, Exchange 2003 processes all the logs until Exchange 2003 reaches a record of a clean shutdown, and because there are more than 1,008 log files, Exchange 2003 reaches the limit of 1,008 log files before Exchange 2003 can locate the record of a clean shutdown. Therefore, you experience the symptoms that are described in the "Symptoms" section.

Note The symptoms that are described in the "Symptoms" section may also occur if the conditions that are listed earlier in the "Cause" section are true, and you replay the log files by using the eseutil /r command. The eseutil /r command also performs a soft recovery on the mailbox store.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version       Size       File name
------------------------------------------------------
05-Mar-2004  17:47  6.5.6980.74   1,963,520  Ese.dll 

WORKAROUND

To work around this issue, move the Exchange log files to a different folder, and then restart the server. This workaround does not apply to a "roll-forward" recovery scenario. To move the Exchange log files to a different folder, follow these steps:
  1. Before you move the log files, make sure that all databases are in a clean shutdown state. Run the eseutil /mh command on each database and on each .stm file to check the shutdown state.
  2. Locate the Mdbdata folder. By default, this folder is located in the following location:

    Drive:\Program Files\Exchsvr

    This folder contains a sequential set of log files that starts with the E00.log log file.

    Note Drive is a placeholder for the drive letter where your Exchange Server program is installed.
  3. Create a new folder on the hard disk to store the log files.
  4. In the Mdbdata folder, select all the E*.log log files except for the first log file and the last five or 10 log files.
  5. Move the log files that you selected earlier in step 4 to the new folder that you created earlier in step 3.
  6. Restart the server. Ignore any error messages that you may receive during startup.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information naming schema for Exchange software update packages, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:11/8/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbBug kbExchange2003preSP1fix KB836611 kbAudITPRO