You cannot restore a mailbox store from one Exchange 2003 server to a Recovery Storage Group on another Exchange 2003 server (836554)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

After you use Backup to make an online backup of a Microsoft Exchange Server 2003 mailbox store, you receive an error message when you try to restore the mailbox store.

You receive the error message when you try to restore the mailbox store to a Recovery Storage Group on another Microsoft Exchange Server 2003 computer that is in the same administrative group. The error message is similar to the following:
The specified computer is not a Microsoft Exchange server or its Microsoft Exchange services are not started.

CAUSE

This behavior may occur if the name of the Recovery Storage Group or the name of any other storage group on the destination Exchange 2003 server is different from the source storage group name.

By default, when you restore from an online backup, Backup requires that the name of the storage group that you backed up appear in the list of storage groups that is retrieved from the destination server. This behavior does not occur when you use Backup to complete an offline backup and restore.

WORKAROUND

To work around this behavior, follow these steps when you use Backup to restore an online backup of a mailbox store:
  1. On the destination Exchange 2003 computer, delete the mailbox store if you have added it to the existing Recovery Storage Group.
  2. Right-click the Recovery Storage Group folder, and then click Properties to verify the location of the folders that are associated with the Recovery Storage Group.
  3. Delete the existing Recovery Storage Group.

    You can manually delete the folders that are associated with the Recovery Storage Group from the location that you noted in step 2. By default, the folders are located at C:\Program Files\Exchsvr\Recovery Storage Group name.
  4. Create a new Recovery Storage Group with the same name as the storage group on the source Exchange 2003 computer.
  5. Restore the online backup to this Recovery Storage Group.
Note You cannot restore public stores to a Recovery Storage Group. You can only restore mailbox stores to a Recovery Storage Group.

MORE INFORMATION

If an Exchange 2003 administrative group contains multiple Exchange servers, you can restore mailbox store databases that are in Recovery Storage Groups on any one of the servers in that administrative group. However, mailbox store databases can only be restored to a Recovery Storage Group on a server that is a member of the administrative group that the data originated from.

If you use Backup to perform an online backup of a mailbox store, you must use the following naming conventions when you try to restore this backup to a Recovery Storage Group:
  • If you create the Recovery Storage Group on the Exchange 2003 computer where the mailbox store was backed up, you can give the Recovery Storage Group any name that you want to use.
  • If you create the Recovery Storage Group on a different Exchange 2003 computer in the same administrative group, you must use one of the following naming conventions:

    Method 1

    1. Create a storage group on the destination computer that has the same name as the source storage group. You do not have to add a database to this storage group.
    2. Create a Recovery Storage Group that has a name that you want to use.
    3. Complete the restore.

    Method 2

    1. Create a Recovery Storage Group that has the same name as the source storage group.
    2. Complete the restore.

REFERENCES

For additional information about Recovery Storage Groups in Exchange 2003, click the following article number to view the article in the Microsoft Knowledge Base:

824126 How to use Recovery Storage Groups in Exchange Server 2003

To download an Exchange technical book about Recovery Storage Groups in Exchange Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:11/10/2005
Keywords:kbprb KB836554 kbAudITPRO