You receive a "The security context is invalid" error message when you call or create an out-of-process component (836533)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0

SYMPTOMS

If a Web site program has been configured for Delegation security in the Component Services management tool, and the Web site is configured for Basic authentication, you may receive the following error message when you try to call or to create an out-of-process component that is on the same computer as Microsoft Internet Information Services (IIS):
0x800706d5, "The security context is invalid."

CAUSE

This problem may occur when the user token that is generated from Basic authentication has the SecurityImpersonation impersonation level instead of the SecurityDelegation impersonation level.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must stop and then restart Internet Information Services after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name          Platform
   ----------------------------------------------------------------------
   26-Feb-2004  19:48  6.0.3790.134  339,968  W3core.dll         X86
   26-Feb-2004  19:48  6.0.3790.134  945,664  W3core.dll         IA64
   19-Jan-2004  22:54                    271  Branches.inf
   26-Feb-2004  19:55                  9,766  Kb836533.cat
   26-Feb-2004  19:49                    354  Updatebr.inf
   26-Feb-2004  19:50                  6,262  Update_rtmqfe.inf
Note This hotfix corrects this problem by using the DuplicateTokenEx function to change the token's impersonation level to SecurityDelegation.

WORKAROUND

To work around this problem, use Integrated security. Integrated security uses Kerberos.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB836533 kbAudEndUser kbAudITPRO