Telnet sessions do not receive the escape character (836529)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.5
  • Microsoft Windows Services for UNIX 3.0
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional

SYMPTOMS

If a Telnet client connects with a terminal type other than NTVT terminal type, escape characters are not received by applications that are running in a Telnet session. For example, escape characters are not received if a Telnet client connects with a terminal that is VT52 type, VT100 type, or ANSI type.

Note This problem does not occur with Telnet clients that support the NTVT terminal type. Windows Telnet clients work as expected.

CAUSE

The escape character is passed to the Telnet session as an enhanced key. However, because the escape character is not an enhanced key, it is not considered to be valid and is discarded.

RESOLUTION

Service pack information

Windows XP

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack or the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
DateTimeVersionSizeFile name
08-Mar-200419:388.0.1969.3142,848Tlntsess.exe
10-Mar-200402:068,798Tlntsvr.cat
08-Mar-200419:388.0.1969.3166,400Tlntsvr.exe
08-Mar-200419:38978Tlntsvr.inf
08-Mar-200419:388.0.1969.314,336Tlntsvrp.dll

WORKAROUND

For Windows Telnet clients, you can use the following command to set the terminal type to VTNT:

telnet -t vtnt

For more information, see the Telnet Client documentation.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbBug KB836529 kbAudITPRO