You receive a "could not find rule store" error message when you start Business Rule Composer in BizTalk Server 2004 (836477)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Standard Edition

SYMPTOMS

If you start the Business Rule Composer tool in Microsoft BizTalk Server 2004 after you have reinstalled BizTalk Server, you receive the following error message:
Could not find rule store on ServerName.

CAUSE

This issue occurs if all the following conditions are true:
  • You remove BizTalk Server 2004.
  • You reinstall BizTalk Server 2004.
  • You configure BizTalk Server 2004 to use a different computer that is running Microsoft SQL Server 2000 than the one that the previous installation used.
In this scenario, the Business Rule Composer tool tries to locate the rule store in an incorrect location.

Note Typically, this issue occurs when you reinstall BizTalk Server. However, this issue may also occur for other reasons.

RESOLUTION

To resolve this issue, open the rule store that is located on the correct computer that is running SQL Server. To do this, follow these steps:
  1. In the Microsoft Business Rule Composer tool, click Load on the Rule Store menu.
  2. In the SQL Server list, click the server where the correct rule store is located, and then click the correct database in the Database list.
  3. Click the authentication method that you want to use. If you click the SQL Server authentication option, enter the credentials to access the database.
  4. Click OK.

MORE INFORMATION

When you start the Business Rule Composer tool, the tool creates registry entries to store the database name and the database server name for the rule store. The Business Rule Composer tool creates these registry entries in the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\BusinessRules\3.0\RuleComposer

If you remove BizTalk Server 2004, these registry entries are not removed. Therefore, when you reinstall BizTalk Server 2004 and then start the Business Rule Composer tool, the tool tries to locate the rule store by using the old RuleStoreDatabase registry value and the old RuleStoreServer registry value that are stored in this registry subkey.

Modification Type:MajorLast Reviewed:2/23/2004
Keywords:kbBTSRules kbprb KB836477 kbAudITPRO