You cannot add a static route to a incoming connection on a Windows 2000-based computer or on a Windows XP-based computer (836439)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use a Windows XP-based or Windows 2000-based computer as a dial-in device for a router, and then you apply static routes to the incoming connections, the PPP/WAN interface does not function after you restart the computer.

CAUSE

This problem occurs because Windows XP and Windows 2000 use the same internal ID for the WAN (PPP/SLIP) interface unless another device already occupies the internal ID. This may occur when you restart the computer and the WAN (PPP/SLIP) interface is applied to a different internal ID.

When you apply a static route to the WAN (PPP/SLIP) interface, the static route uses the current internal ID and retains this information permanently. When you restart the computer, the static route may reference an ID that now belongs to another device.

WORKAROUND

To work around this problem, turn on RIP Listening. To do so, follow these steps:

Note You must be an administrator or member of the Administrator group to follow these steps. If you computer is connected to network, the network policy settings may interfere with these steps.
  1. Click Start, click Control Panel, and then click Add or Remove Programs.
  2. Click Add/Remove Windows Components.
  3. In the Components box, click Networking Services, and then click Details.
  4. Click to select the RIP Listener check box, and then click OK.
  5. Click Next, and then complete the wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:3/9/2004
Keywords:kbnetwork kbprb KB836439 kbAudITPRO