When you start Encarta or games for Windows, you receive an error message because of an error that occurs in Aclayers.dll (836204)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III Expansion: The War Chiefs
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: Gold Edition
  • Microsoft Age of Mythology: The Titans
  • Microsoft Encarta Reference Library 2003 1.0
  • Microsoft Encarta Reference Library 2004 DVD-ROM
  • the operating system: Microsoft Windows 2000
  • the operating system: Microsoft Windows XP
  • Microsoft Flight Simulator 2004 - A Century of Flight
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Thrones and Patriots

SYMPTOMS

When you try to start one of the programs listed in the "Applies To" section, the program may quit unexpectedly, and you may receive an error message that resembles the following:
Microsoft Program has encountered a problem and needs to close. We are sorry for the inconvenience.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature that is similar resembles the following:
AppName:	AppVer:		ModName:		ModVer:		Offset:
appname		appver		aclayers.dll		5.1.2600.2180  00012f5C
Where appname is one of the following:
  • age3.exe
  • aom.exe
  • aomx.exe
  • encarta.exe
  • rise.exe
  • nations.exe
  • thrones.exe

CAUSE

This issue occurs when the game's shortcut is set to use a compatibility mode. The Microsoft XML 4.0 that is used by some games and by Microsoft Encarta is not compatible with the Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition compatibility modes in Microsoft Windows 2000 and Microsoft Windows XP.

RESOLUTION

To resolve this issue, follow these steps:
  1. Right-click the shortcut icon for the program, and then click Properties.
  2. On the Compatibility tab, click to clear the Run this program in compatibility mode for: check box.

    Alternatively, on the Compatibility tab, select the compatible mode Windows 2000.
  3. Click OK.
  4. Start the program with the shortcut that you just modified.
If this issue still occurs after you follow these steps, create a new user account, and then try to start the program as the new user.
For more information about how to create and configure user accounts in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

279783 How to create and configure user accounts in Windows XP

MORE INFORMATION

For more information about program compatibility, click the following article number to view the article in the Microsoft Knowledge Base:

301911 How to use the Program Compatibility Wizard in Windows XP


Modification Type:MajorLast Reviewed:10/2/2006
Keywords:kbui kberrmsg kbprb KB836204 kbAudEndUser