You receive an "An unrecoverable error has occurred" error message or a "Money has encountered a problem and needs to close" error message when you start Money (836197)



The information in this article applies to:

  • Microsoft Money Essentials
  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium
  • Microsoft Money Deluxe 2006
  • Microsoft Money Premium 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money 2005 Deluxe
  • Microsoft Money 2005 Premium
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2005 Standard
  • Microsoft Money 2004 Deluxe
  • Microsoft Money 2004 Premium
  • Microsoft Money 2004 Small Business
  • Microsoft Money 2004 Standard
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money 2003 Standard
  • Microsoft Money 2002

SYMPTOMS

When you start one of the versions of Microsoft Money that are listed in the "Applies to" section, you receive one of the following error messages.

Error message 1

An unrecoverable error has occurred.
AppName:msmoney.exe
ModName:mnyob99.dll

Error message 2

Money version has encountered a problem and needs to close. We are sorry for the inconvenience.
In this error message, version is the version of Microsoft Money that is installed on the computer.

Additionally, when you click Click here in either error message, you receive the following message:AppName: msmoney.exe
ModName: mnyob99.dll or uparser2.dll

CAUSE

This issue may occur if one or more of the following conditions are true:
  • The Msxml.dll files are corrupted or are not registered correctly.
  • The Microsoft Internet Explorer settings are incorrect.
  • The installation of Money is corrupted.

RESOLUTION

To resolve this issue, use one or all the following methods until the issue is resolved.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Method 1: Reregister the MSXML DLL files

To reregister the MSXML DLL files, follow these steps:
  1. Type the following commands at a command prompt. Press ENTER after you type each command.

    regsvr32 c:\winnt\system32\msxml.dll

    regsvr32 c:\winnt\system32\msxml3.dll

    regsvr32 c:\winnt\system32\msxml4.dll

    Note Depending on where Microsoft Windows was installed, you may have to change the path in the commands that are listed if Windows was not installed to C:\WinNT.
  2. Start Money.
  3. If the issue is not resolved, download and install MSXML.

    To download Microsoft MSXML 4.0 Service Pack 2 (Microsoft XML Core Services), visit the following Microsoft Web site:
  4. Download and install Microsoft Data Access Components (MDAC) 2.8.

    To do this, visit the following Microsoft Web site:
  5. Download and install Microsoft Windows Script 5.6.

    To do this, visit the following Microsoft Web site:
  6. Reregister the MSXML DLL files as described in step 1.
  7. Restart the computer.

Method 2: Reset the Internet Explorer security settings

To reset Internet Explorer security settings, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options, and then click the Security tab.
  3. Click the Internet Web content zone, and then click Default Level.
  4. Click the Advanced tab, click Restore Defaults, and then click OK.
  5. Quit Internet Explorer.

Method 3: Uninstall and reinstall Money

For more information about how to uninstall and reinstall Money, click the following article number to view the article in the Microsoft Knowledge Base:

895866 How to remove and reinstall Microsoft Money


Modification Type:MinorLast Reviewed:8/20/2006
Keywords:kbprb KB836197 kbAudEndUser