Memory leaks occur when you use Active Directory discovery methods in Systems Management Server 2003 (836145)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you use any one of the Active Directory discovery methods on a Microsoft Systems Management Server (SMS) 2003 site, you may experience any or all the following conditions:
  • The SMS Executive service stops responding

    The subcomponents of the SMS Executive service stop updating their respective log files. Task Manager shows that the SMSExec.exe process is using large amounts of physical and virtual memory. The following entry appears in the log of SMS components, such as Discovery Data Manager or Collection Evaluator, that connect to the SQL server:
    *** [0][Microsoft][ODBC SQL Server Driver]Memory allocation failure
    *** [0][Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_DBC failed
    *** Failed to connect to the SQL Server.
    Performance may be slow for other programs and for other processes that run on the SMS site server computer.

    Note SMS log files indicate that Active Directory discovery methods stop responding for long periods of time when large Active Directory containers are scanned. If other SMS components continue to log activity or to process data regularly, you are not experiencing the problem that is described in this article.
  • An access violation error occurs in the SMS Executive component

    The crash.log file references one of the following discovery components:
    • SMS_AD_SYSTEM_DISCOVERY_AGENT
    • SMS_AD_SYSTEM_GROUP_DISCOVERY_AGENT
    • SMS_AD_USER_DISCOVERY_AGENT
    However, the computer frequently does not have the system resources to generate a complete log.
  • The HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Inbox Source\Inbox Definitions\0 registry subkey no longer references Site Control Manager. Instead, the Inbox Name and Relative Path entries reference either Discovery Data Manager or Collection Evaluator. These components log the following entry in the respective log files:
    Createded inbox def 0

    Note In this error message, the word "Createded" is a misspelling for the word "Created."

CAUSE

This problem occurs because of memory leaks that are caused by the ADSource.dll file. All three Active Directory discovery methods share this file. The leaks occur most frequently in networks with many computers, and when you use multiple Active Directory discovery methods at the same time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, SMS 2003 services stop and restart when you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Feb-2004  14:24                     11,546  Filemap.ini
   13-Feb-2004  20:28  2.0.6.6           354,368  Smsupdate.exe    
   25-Dec-2003  07:00  2.50.2726.112     114,688  Adsource.dll     
   06-Aug-2000  06:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  07:05  2.0.1493.5011     855,312  Preinst.exe 
Note If the SMS site server computer is in a low-resource state, stop and then restart the SMS Executive service before you apply this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about the "Createded inbox def 0" log file entry, click the following article number to view the article in the Microsoft Knowledge Base:

834617 You receive error messages and scheduled updates do not occur when you start SMS Service Manager in SMS 2003

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbActiveDirectory kbServer KbClientServer kbSMSTopazFix kbPerformance kbDiscovery kbfix kbBug KB836145 kbAudITPRO