You cannot remove an attachment from a custom form by using Outlook Web Access in Exchange Server 2003 (835779)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you try to remove an attachment from a custom form by using Microsoft Outlook Web Access (OWA), you receive the following error message:
The page cannot be displayed

There is a problem with the page you are trying to reach and it cannot be displayed.

Please try the following:
  • Click the Refresh button, or try again later.
HTTP 500.100 - Internal Server Error - Forms Renderer Error
Web Storage System Forms Rendering Engine

Technical Information (for support personnel)
  • Error Type:

    Server Error
    HrResolveMimeUrl failed, hr=0x800cce05.
  • More information:
    Microsoft Support

CAUSE

This problem occurs if the file name of the attachment contains a special character, such as an ampersand (&). For example, you cannot remove an attachment that is named Test&File.txt.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ------------------------------------------------------
   27-Feb-2004  00:54  6.5.6980.72  692,736  Exwform.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

This hotfix only fixes the problem in OWA custom form items that are created after you apply the hotfix. You will not be able to delete any attachments whose filenames contain special characters that are attached to OWA custom forms that existed before you applied the hotfix. To correct this problem for OWA custom forms that existed before you applied the hotfix, remove the form items, and then re-attach the files.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbExchange2003preSP1fix kbQFE kbfix kberrmsg kbBug KB835779 kbAudEndUser kbAudITPRO