The Information Store service quits unexpectedly with an access violation in Exchange Server 5.5 (835632)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

SYMPTOMS

The Microsoft Exchange Server 5.5 Information Store service (Store.exe) may quit unexpectedly with an access violation.

CAUSE

This problem may occur when Exchange Server parses a string in the PR_BODY property of a message that is not terminated with a NULL character. Specifically, this problem may occur when both of the following conditions are true:
  • Non-delivery report (NDR) messages are delivered to Microsoft Office Outlook 2003 users who use an Internet Mail Access Protocol (IMAP) e-mail account.
  • These NDR messages are moved between the personal folder (.pst) file and the IMAP folder.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Microsoft Exchange Server 5.5 Service Pack 4 (SP4).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size    File name
------------------------------------------------------      
01-Apr-2004  23:39  5.5.2658.4     496,400  Mdbmsg.dll       
01-Apr-2004  23:39  5.5.2658.4   2,635,024  Store.exe 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:1/16/2006
Keywords:kbHotfixServer kbQFE kbExchange550preSP5fix kbBug kbfix kbQFE KB835632 kbAudITPRO