Post-installation scripts do not install programs successfully when Windows Server 2003 is installed from a Sysprep image (835330)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you configure a script or a batch file to install programs immediately after Microsoft Windows Server 2003 is installed, the programs that the script or that the batch file installs are not installed correctly.

Note You only experience this problem when Windows is installed from a Sysprep.exe image.

CAUSE

This problem occurs when the script or the batch file installs programs that must register components with the Windows Management Instrumentation (WMI) service. In this scenario, when Windows restarts after being installed from a Sysprep image, and when components try to register with the WMI service, the following behaviors occur:
  • The first component registration is successful.
  • Subsequent component registrations are unsuccessful.
This problem occurs because the Winmgmt.exe process is not completely initialized when the computer restarts after the installation is complete. Typically, the Winmgmt.exe process requires about 2 to 4 minutes to be initialized when Windows first starts after it is installed from a Sysprep image. When Windows starts, WMI creates an inventory of all the driver additions and class additions to the Web-Based Enterprise Management (WBEM) repository. During the first restart after Windows is installed, there are many driver and class additions. Therefore, the Winmgmt.exe process requires additional time to initialize.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, 32-bit editions
File nameFile versionFile sizeDateTimePlatformService branch
Wmiprvsd.dll5.2.3790.142416,25620-Apr-200419:57x86RTMQFE
Wmiprvse.exe5.2.3790.142206,84820-Apr-200419:57x86RTMQFE
Microsoft Windows Server 2003, 64-Bit Enterprise Edition
File nameFile versionFile sizeDateTimePlatformService branch
Wmiprvsd.dll5.2.3790.1421,445,88817-Mar-200403:31IA-64RTMQFE
Wmiprvse.exe5.2.3790.142731,64817-Mar-200401:35IA-64RTMQFE

WORKAROUND

To work around this problem, insert a delay in the script or the batch file that starts when the Windows installation is complete. If you insert a delay of about 5 minutes between the time that Windows starts and the time that component registration starts, the WMI service does not hang, and all components are successfully registered.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:2/1/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB835330 kbAudITPRO