SYMPTOMS
In Microsoft Business Solutions CRM 1.0, a copy operation may fail when you try to copy a role. You may also receive one of the following Error messages in the event log of the Microsoft CRM server program:MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147205110 (0x80044005)
Description: <description> Invalid code for CRM error </description>
<details> Connection failure SQL State - 08501, Native error -0 </details>
<file>&:\crm\build\3297\src\platform\include\OMCommon\dataccess.inl </file>
<line> 324 </line> MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147024809 (0x80070057)
Description: The parameter is incorrect. MSCRMSecurity Service
Event ID:6148
Error: Some security descriptors could not be adjusted after a privilege change. -2147463168 (0x80005000)
Description: <could not load message>
Comments: GetRoleSids() failed:%d
Users who are assigned one of these roles that is new or copied may not be able to log on to the Microsoft CRM server. Users may also receive any one of the following error messages:
Access Denied "User has not been granted any licenses or the user has not been assigned any roles."
License Error "The selected user or user trying to log on has not been assigned a security role or license, and does not have sufficient privileges for this action. For more information, contact your system administrator."
Users who use Microsoft CRM may also receive the following error message when they perform an action:
The selected user does not have sufficient privileges for this action.
The users' roles should let them perform the action.
CAUSE
This problem may occur if one of the following conditions is true:
- You create or copy a Microsoft CRM role in an environment that has a slow instance of Microsoft SQL Server.
- There are hundreds of thousands or millions of records in the Microsoft CRM databases.
The role-creation operations and the copy operations update every record in Microsoft CRM that contains a security descriptor. The security descriptor contains information about the access privileges that Microsoft CRM users have to that record. These privileges are based on the Microsoft CRM roles that have been assigned to the users.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft Business Solutions CRM that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Installation information
Install this hotfix on every Microsoft CRM server.
Prerequisites
Microsoft CRM 1.0 must be installed before you install this hotfix.
Removal information
You cannot remove this hotfix.
Restart requirement
The Microsoft CRM Security Service is restarted during the installation of this hotfix. When this service is restarted, operation of Microsoft CRM is temporarily interrupted. Therefore, install this hotfix after regular business hours. Or, schedule five minutes for all Microsoft CRM users to be logged off Microsoft CRM while you install this hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
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13-Apr-2004 16:07 1.0.3017.101 490,208 Crmsecurityservice.exe