SYMPTOMS
When you use Riprep.exe to upload a Microsoft Windows XP Professional image or a Microsoft Windows 2000 Professional image to a Microsoft Windows 2000-based Remote Installation Services (RIS) server, you may receive the following error message:
Missing CD-ROM Image on Server
The RIS server to
which you are attempting to post this installation does not contain the correct
CD-based image. The version of the CD-based image on the server must match the
version of the system you are attempting to image[Version 5.1 Build 2600,
Language English]. Please either select a different RIS server to post this
installation to or add the corresponding CD-based image to the current RIS
server.
CAUSE
This problem may occur if one of the following conditions is
true:
- The Boot Information Negotiation Layer (BINL) service cannot find an image on the RIS server that has the same version of the Ntoskrnl.exe file as the version in the image.
- You install a hotfix or an update that updates Ntoskrnl.exe
in the installation image.
- Before you run Riprep.exe, you integrate a hotfix or an update that includes
Ntoskrnl.exe in an installation.
Important We do not recommend that you use an original equipment manufacturer (OEM) installation to install corporate images when you use Risetup.exe or Riprep.exe. Typically, OEM installations are designed specifically for that hardware. You may experience activation issues or licensing issues when you deploy the image. We recommend that you use volume-licensed media.
For more information about Microsoft Volume Licensing, visit the following Microsoft Web site:
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
This fix requires that you update the version of Remote Installation Preparation (RIPrep) on the RIS server to the version that is included with Windows Server 2003. If you have an existing Windows Server 2003-based RIS server,
copy the files from the
Drive_letter:\Remoteinstall\Admin\I386 folder to the Windows 2000-based RIS server.
If
you have a Windows Server 2003 CD, you can extract the required files. To do this, follow these steps.
Note If you have already tried to create a RIPrep image, you must
restart your Windows 2000-based computer before you follow these steps.
- Right-click Start, and then click
Explore to start Microsoft Windows Explorer.
- Rename the following files in the
Drive_letter:\Remoteinstall\Admin\I386 folder:
- Riprep.exe
- Riprep.inf
- Setupcl.exe
- Quit Windows Explorer.
- Insert the Windows Server 2003 CD into
your CD or DVD drive.
- Click Start, click
Run, type cmd in the Open box, and then click
OK.
- Type expand
CD_drive_letter:\i386\riprep.ex_
Drive_letter:\Remoteinstall\admin\i386\riprep.exe,
and then press ENTER.
- Type expand
CD_drive_letter:\i386\riprep.in_
Drive_letter:\Remoteinstall\admin\i386\riprep.inf,
and then press ENTER.
- Type expand
CD_drive_letter:\i386\setupcl.ex_
Drive_letter:\Remoteinstall\admin\i386\setupcl.exe,
and then press ENTER.
- Type exit, and then press ENTER.
- Eject the Windows Server 2003 CD.
If
you do not have access to a Windows Server 2003 CD or to a Windows Server 2003-based
RIS server, follow the instructions in the "Workaround" section.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file
attributes (or later) that are listed in the following table. The dates and
times for these files are listed in coordinated universal time (UTC). When you
view the file information, it is converted to local time. To find the
difference between UTC and local time, use the
Time Zone tab
in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------
05-Feb-2004 20:13 5.0.2195.6894 97,552 Binlsvc.dll
WORKAROUND
To work around this problem, remove the hotfix or the update,
and then reinstall the update after the Setup program is completed. To
automatically install the update after the Setup program is completed, add the
update file to the [GuiRunOnce] section of the Riprep.sif file. Use the
following format, where
<nnnnnn> represents the numeric part of the
update file name:
[GuiRunOnce]
%windir%\q<nnnnnn>.exe /q
The Riprep.sif file is located in the following folder:
Drive_letter:\RemoteInstall\Setup\English\Images\Imagename\I386\Templates
Note You must copy the hotfix to this location. When an administrator
logs on to the destination computer automatically or manually, the update is
applied, and the computer restarts.