Content that is returned in search results is not sorted as you expect in SharePoint Portal Server 2003 (835239)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

When you search the portal site in Microsoft Office SharePoint Portal Server 2003, you may find that content that is returned in the search results is not sorted as you expect. For example, when you search the portal site for your user name, your user name is not listed as the first item that is returned in the search results. Your user name appears randomly in the list of items that are returned in the search results.

CAUSE

This problem occurs if the ranking of items in the search results is not processed correctly in SharePoint Portal Server 2003. This problem occurs after you install the hotfix that is described in the following article in the Microsoft Knowledge Base:

831203 Content that is outside the search scope is unexpectedly returned in the search results when you search a portal site that is in your SharePoint Portal Server server farm

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Date         Time   Version            Size    File name
-----------------------------------------------------------------------------
20-Jan-2004  05:10  11.0.5704.15   4,602,616  Microsoft.SharePoint.Portal.dll 
 
Note This update requires SharePoint Portal Server 2003. You may have to restart your computer after you apply this update.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbDeployment kbfix kbBug kbSharePtPortalSvr2003preSP1fix kbQFE kbHotfixServer KB835239 kbAudITPRO