You receive a "DRIVER_IRQL_NOT_LESS_OR_EQUAL STOP 0xD1" error message, and your Windows 2000 Server-based computer stops responding (834938)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

For a Microsoft Windows Server 2003 version of this article, see 835166.
For a Microsoft Windows NT 4.0 version of this article, see 825784.

SYMPTOMS

Your Microsoft Windows 2000 Server-based computer stops responding, and you receive a STOP 0xD1 error message that is similar to the following:
DRIVER_IRQL_NOT_LESS_OR_EQUAL

CAUSE

This problem occurs because of a problem in the SCSIPORT driver. The problem occurs when incorrect areas of memory are overwritten or are written to disk. This problem occurs only with SCSIPORT drivers that do not use map buffers for I/O transfers. To determine whether your SCSIPORT driver uses map buffers, contact your Independent Hardware Vendor (IHV) or your Original Equipment Manufacturer (OEM).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   04-Feb-2004  19:11  5.0.2195.6896      74,256  Scsiport.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWin2000preSP5fix kberrmsg KB834938 kbAudITPRO