FIX: You may receive a blank page when you try to compare two pages in a WBC in Edit mode (834920)



The information in this article applies to:

  • Microsoft Content Management Server 2002 SP1

SYMPTOMS

If you try to view two postings to compare the revision history in a Web Browser Client (WBC) in Edit mode, you may receive a blank Web page.

CAUSE

This problem occurs because the compare revision process called the PageRevisionCommon.js file, but the file no longer exists. If the user has a custom 404 error message in the Web.config file, it causes the PageRevisionCommon.js file to be returned as an HTML page. Because of this, you may receive a blank Web page in Microsoft Internet Explorer.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Content Management Server 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Size  File name
   ----------------------------------------------------------
   30-Jan-2004  02:06   7,789  Pagerevisioncompareinfo.aspx
   30-Jan-2004  02:06  15,210  Pagerevisioncompareresult.aspx
   30-Jan-2004  02:06  16,048  Pagerevisionhistory.aspx   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbbug kbfix kbContentMgtServ2002SP2Fix kbContentMgtServ2002preSP2Fix KB834920 kbAudDeveloper