Windows Server 2003 logs Event ID 51 although no data has been lost from the hard disk (834910)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you have a hard disk storage array that is configured in your Microsoft Windows Server 2003-based computer, Event ID 51 may appear many times in the system log in Event Viewer with a description that is similar to the following:Event Source: Disk
Event Category: None
Event ID: 51
Date: date
Time: time
Type: Warning
User: N/A
Computer: computername
Description: An error was detected on device \Device\Harddisk7 during a paging operation. For more information, see Help and Support Center at http://support.microsoft.com.
Data:

These events may occur when when you add or remove a hard disk device from a Storage Area Network (SAN) array to Windows Server 2003. This hard disk device is also known as a Logical Unit Number (LUN).

CAUSE

This problem occurs if an Input/Output (I/O) operation to a hard disk is unsuccessful. When an I/O operation to a hard disk is unsuccessful, Windows Server 2003 logs Event ID 51 in the system log. This problem occurs even if the I/O operation is retried and is subsequently successful.

When you add or remove a new LUN from a NAS array to Windows Server 2003, Windows may log Event ID 51. This event appears even if the I/O operation was successful after a retry. In Windows versions that are earlier than Windows Server 2003, these operations do not cause Event ID 51 messages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You may have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jan-2004  02:12  5.2.3790.123       61,952  Classpnp.sys
Microsoft Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jan-2004  01:20  5.2.3790.123      145,408  Classpnp.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

After you install this hotfix, Windows logs Event ID 51 only if an I/O request is unsuccessful after all the subsequent retry operations have completed.

Event ID 51 typically appears in the system log if an I/O operation to a hard disk is unsuccessful. In this scenario, troubleshoot the hard disk subsystem to determine the cause of the error. Windows Server 2003 also logs vendor-defined unit attention operations. Event ID 51 may also appear when you add a new LUN to Windows Server 2003. When all the connected LUNs are performing I/O operations, unit attention that is generated on those LUNs causes the generation of Event ID 51 events when you add a new LUN. In this case, the I/O operation is retried successfully, and no additional troubleshooting is required. This problem does not occur in Microsoft Windows 2000.

For additional information about Event ID 51, click the following article number to view the article in the Microsoft Knowledge Base:

244780 Information about Event ID 51


For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB834910 kbAudITPRO