The SHIFT+F10 keyboard shortcut does not close a shortcut menu in Internet Explorer on a Windows 2000-based computer (834806)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you view a Web page in Microsoft Internet Explorer on a Microsoft Windows 2000-based computer, and you use the SHIFT+ F10 keyboard shortcut to display the shortcut menu for a selected item, the shortcut menu may not close as expected when you press SHIFT+F10 again. In this scenario, Internet Explorer stops responding (hangs).

CAUSE

Every time that you press SHIFT+F10, the system tries to open a shortcut menu, even when a shortcut menu is already open. Therefore, if you press SHIFT+F10 when a shortcut menu is already open, Internet Explorer stops responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Windows 2000 Service Pack 4

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   11-Feb-2004  21:05  5.0.3900.6897     793,360  Browseui.dll        

WORKAROUND

To work around this problem, do not use the SHIFT+F10 keyboard shortcut to open a shortcut menu. Instead, use your mouse to open the shortcut menu for an item. To do this, follow these steps:
  1. Position the mouse pointer over the item that you want to open the shortcut menu for.
  2. Right-click the item. The shortcut menu opens.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB834806 kbAudEndUser