FIX: You cannot rename or copy a file in a Web folder in SharePoint Portal Server 2003 (834708)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

After you install the client components for Microsoft Office SharePoint Portal Server 2003 on your computer, you may find that you cannot copy or rename a file in a document library in Microsoft Office SharePoint Portal Server 2003. This problem occurs when you connect to the portal site by using a network place shortcut that you created by using Web Distributed Authoring and Versioning (WebDAV). When you rename a file in a Web folder, you receive an error message that is similar to the following:
Unable to rename URL of Folder

CAUSE

This problem may occur if both of the following conditions are true:
  • The name of the file that you want to rename or to copy is different from the value of the DAV:displayname property of the file.
  • You are using an Apache Web server.
In this situation, an incorrect URL is sent to the server when you rename or copy the file by using Web folders.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version          Size    File name
---------------------------------------------------------
30-Jan-2004  07:38  11.0.5716.1   1,293,008  Msonsext.dll 

Note You may have to restart your computer after you apply this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbsetup kbSharePtPortalSvr2003preSP1fix kbfix kbbug KB834708 kbAudITPRO