FIX: You may receive "The command you selected is not available from this shortcut" error message when you use the Open dialog box or the Save dialog box in Excel 2003 (834681)



The information in this article applies to:

  • Microsoft Office Excel 2003

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use the Open dialog box or the Save dialog box in Microsoft Office Excel 2003, you may receive the following error message:

The command you selected is not available from this shortcut.


You may receive this error message even if you are not using the shortcut menu or even if you are not performing an action in the Open dialog box or in the Save dialog box. The error message may appear multiple times until you close the Open dialog box or the Save dialog box.

CAUSE

This problem occurs if the instance of Excel that you are running also contains a third-party add-in program or a utility that issues Dynamic Data Exchange (DDE) requests to Excel from a timer or from a secondary thread while the dialog box is displayed. For the problem to occur, the calling DDE client must be in-process to Excel.

When Excel receives a DDE request while the Open dialog box or the Save dialog box is displayed, Excel checks the process of the caller to try to determine if the call comes from inside Excel. If Excel determines that the call comes from inside Excel, Excel concludes that the command is issued by the Shell view that is hosted in the dialog box. Excel then checks the command to see if the action is supported. If the command is issued by an add-in program that is trying to run a background task, the call may be incorrectly detected, and you may receive the error message that is mentioned in the "Symptoms" section by mistake. The DDE command is not processed, and the caller receives the error that the request failed. If the DDE caller ignores the error and then sends the command again, you may receive the error message every time until you close the Open dialog box or the Save dialog box.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest Office 2003 service pack, you do not have to install the hotfix.

Service pack information

After you install the service pack, follow the steps that are listed in the "More Information" section of the article to set the HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Options and to activate the fix.

Hotfix information

This problem is corrected in Office 2003 Service Pack 1.To resolve this problem, obtain the latest service pack for Microsoft Office 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

870924 How to obtain the latest service pack for Office 2003



How to obtain the hotfix

This issue is fixed in the Microsoft Office Excel 2003 Hotfix Package that is dated February 29, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

833855 Excel 2003 Hotfix Package: February 29, 2004

After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the Qfe_Sydney registry key and to activate the hotfix.
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.This problem was first corrected in Office 2003 Service Pack 1.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To activate this hotfix, follow these steps:
  1. Quit Microsoft Office Excel 2003.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Options

  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type Qfe_Sydney, and then press ENTER.
  7. Right-click Qfe_Sydney, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbOffice2003sp1fix kbOffice2003preSP1fix kbfix kbBug KB834681 kbAudITPRO kbAudDeveloper