Terminal Services licensing mode changes from Per User or from Per Device to an invalid value after you add or remove a Windows component (834651)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

An invalid setting in the registry may be set in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\Licensing Core\PolicyAcOn subkey on your Microsoft Windows Server 2003-based computer that is configured as a terminal server using a Per User or Per Device licensing setting. This may unexpectedly change the terminal server licensing mode and cause the terminal server to obtain only temporary licenses.

CAUSE

This problem occurs when you use the Windows Components Wizard in Add/Remove Programs to add or to remove a Windows component.

The value of the PolicyAcOn registry entry changes from either 2 for Per Device mode or 4 for Per User mode to an invalid value of 0. Because of this invalid value, the terminal server is not aware of the type of licenses it should obtain. Therefore, the terminal server starts trying to obtain temporary, Per Device licenses. The terminal server configuration shows only Per Device as the licensing mode setting. Therefore, to determine whether the problem described here has occurred, examine the value of the PolicyAcOn registry entry.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit Editions
   Date         Time   Version       Size     File name
   ----------------------------------------------------
   13-Jan-2004  18:17  5.2.3790.118  135,168  Tsoc.dll
Windows Server 2003, 64-Bit Editions
   Date         Time   Version       Size     File name  Platform
   --------------------------------------------------------------
   13-Jan-2004  18:15  5.2.3790.118  303,616  Tsoc.dll   IA-64

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you apply the hotfix, you must reset the PolicyAcOn registry entry to the correct setting of either 4 (Per User) or 2 (Per Device) to configure the licensing mode.

NoteWhen you change the value in the registry as described in the following steps, you will not change the setting that is shown in the Terminal server configuration interface.

To reset the registry values, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\LicensingCore

  3. Right-click the PolicyAcOn registry entry, and then click Modify.
  4. In the Value data box, type 4, and then click OK.

    Note A setting of 2 indicates a Per Device configuration. A setting of 4 indicates a Per User configuration.
  5. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about terminal server licensing, click the following article number to view the article in the Microsoft Knowledge Base:

294716 Microsoft Windows Server 2003 Terminal Server Licensing white paper is now available

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB834651 kbAudITPRO