"Service Pack installation did not complete" error message when you try to install a Windows 2000 service pack (834647)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SUMMARY

When try to install a Windows service pack, you may receive an error message that tells you that the service pack did not install correctly. This issue may occur if you do not have the required registry permissions. This issue may also occur if there is a problem with your user profile. You can identify this issue by examining the Svcpack.log and Setupapi.log files. After you identify the issue, you can resolve it by correcting the permissions on the affected registry keys or by recreating your user profile, depending on the issue that you identify.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When try to install a Windows service pack, you may receive an error message that is similar to the following:
Service Pack installation did not complete. Select 'OK' to undo the changes that have been made, or select 'Cancel' to quit. If you select 'Cancel', your system will be left in a partially updated state and may not work correctly.

CAUSE

This issue may occur if the default user profile is missing. This issue may allso occur if the user who tries to install the service pack does not have the required permissions in the registry.

RESOLUTION

To help identify and resolve this issue, check log files for records of errors that indicate issues that are related to registry permissions. If no such records exist, the issue may be related to a problem with your user profile. When you identify the problem, use the appropriate resolution below.

Part 1: Identify the issue

Check Svcpack.log

By default, the Svcpack.log file is located in the C:\Winnt folder. Open Svcpack.log, and then look for a record of an error that is similar to the following:
DoRegistryUpdates:SetupInstallFromInfSection Failed for IE5Section: 0x5.


This error indicates that the inability to completely install the service pack may be related to registry permissions issues.

Check Setupapi.log

The Setupapi.log will only record registry access problems when verbose logging for GUI-mode Setup is enabled. For additional information about how to enable verbose logging for GUI-mode Setup, click the following article number to view the article in the Microsoft Knowledge Base:

243996 How to enable verbose logging for GUI-mode Setup


If you enable verbose logging after you try to install the service pack, try again to install the service pack so that the process is logged. Open Setupapi.log, and then look for a record of an error that is similar to the following:
09:40:25.452 : Setting reg key HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4\1400 @ 09:40:30.030 : Error Access is denied.
This error also indicates that the inability to completely install the service pack may be related to registry permissions issues. Note any records with an error that is similar to this where the time and date of the error match the time and date when you tried to install the service pack. Make a note of each registry key that is associated with each of these errors.

Check the user profile

You may be able to determine if there is a problem with your user profile by checking the event log. If the symptom that is described in this article is caused by a problem with your user profile, an event that is similar to the following is logged event log:Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Date: 06.03.2004
Time: 17:26:26
User: NT AUTHORITY\SYSTEM
Computer: COMPUTER_NAME
Description:
Windows cannot load the user's profile but has logged you on with the default profile for the system.

Part 2: Resolve the issue

Correct the registry settings

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.If the log files contain errors that indicate that the issue you are experiencing is related registry permission settings, correct them. To do so, follow these steps:
  1. Click Start, click Run, and then type regedt32 to start Registry Editor.
  2. Locate, and then click the registry key or keys that you noted from the Setupapi.log file.
  3. Click Permissions on the Security menu.
  4. In the Permissions box, click the user account that you use to install the service pack.
  5. Under Permissions for User, click to select the Full Control check box.
  6. Repeat these steps for each registry key you noted from the Setupapi.log file.
  7. Install the service pack again.

If the registry key or keys that you noted from the Setupapi.log file are not present, there may be a problem with your user profile.

Replace the Default User profile

If the registry keys that you noted from the Setupapi.log file are not present, or if you still experience the symptom that is described in this article after you correct the registry settings, there may be a problem with your Default User profile. To replace the Default User profile, follow these steps:
  1. Find the C:\Documents and Settings folder, and then check to see if the Default User folder is present.

    If the Default User folder is not present, copy it from another Windows 2000 installation. To do this, you have to have access to another Windows 2000-based computer that has a good Default User folder. If you do not have access to another Windows 2000-based computer, you can create a parallel installation of Windows on your computer, copy the Default User folder to the C:\Documents and Settings folder, and then remove the parallel installation.
  2. Delete the user profile that you used to install the service pack.

    Important When you delete the user profile, all the documents and settings that saved for that profile are lost. They will be replaced by default settings the next time that you log on as that user. Make sure to back up any documents and settings that you do not want lose. This includes the following:
    • Items that stored on the desktop
    • Items that are stored in My Documents
    • Favorites
    • Start menu customizations
    • Internet cookies
  3. Log off, and then log on again as the user you used to install the service pack.
  4. Install the service pack again.

REFERENCES

REFERENCES


Modification Type:MajorLast Reviewed:3/30/2004
Keywords:kbwinservsetup kbprb KB834647