FIX: BizTalk Server Accelerator for RosettaNet incorrectly puts an empty element in the ServiceHeader element (834523)



The information in this article applies to:

  • Microsoft BizTalk Server Accelerator for RosettaNet, version 2.0

SYMPTOMS

When you send a RosettaNet message to your trading partner by using Microsoft BizTalk Server Accelerator for RosettaNet version 2.0, the message may be rejected.

CAUSE

This problem may occur if the ServiceHeader element in the message contains an empty partnerDefinedPIPPayloadBindingId.ProprietaryReferenceIdentifier element.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   ---------------------------------------------------
   15-Jan-2004  12:46  41,959  Contexttoheaders_v2.xml
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbbug KB834523 kbAudDeveloper kbAudITPRO