Audio or video only works in one direction in a real-time communication session (834481)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003
  • Microsoft Windows Messenger 5.0

SYMPTOMS

When users try to participate in a two-way real-time communication (RTC) session by using an RTC client program such as Windows Messenger or MSN Messenger, one party receives audio or video, but the other party does not. This issue occurs even when the RTC client programs, audio devices, and video devices are correctly configured on both computers. However, the users can successfully communicate with each other by using instant messaging.

CAUSE

This issue may occur if one of the client computers has an Intel network adapter installed. This issue occurs because of a problem with version 7.0.26.0 of the E100b325.sys network adapter driver file. This version of the driver incorrectly marks outgoing real-time transport protocol (RTP) packets with 802.1p tags. Because the packets are marked with 802.1p tags, the receiving network adapter drops them, and audio or video communication is lost in one direction.

RESOLUTION

To resolve this issue, install version 7.1.8.0 of the E100b325.sys network adapter driver file on the affected computer. To obtain this driver, visit the Microsoft Windows Update Web site: The E100b325.sys network adapter driver file is available in the Driver Updates section of this Web site. The name of the driver is "Intel network software update released on October 28, 2003."

MORE INFORMATION

Session Initiation Protocol (SIP) clients use the RTP protocol to transfer audio and video data after an audio or video call has been established. RTP is specified in RFC 1889.

The issue that is described in this article is known to occur with network adapters including the Intel PRO/100 V and the Intel PRO/100 Management adapter. To verify the version of the installed network adapter driver, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, and then click Control Panel.
  2. If Control Panel is in Category view, click Switch to Classic View.
  3. Double-click Network Connections, right-click Local Area Connection, and then click Properties.
  4. On the General tab, click Configure.
  5. Click the Driver tab, and then click Driver Details.
  6. In the Driver files box, view the network adapter driver file name and file version.
If the version of the E100b325.sys network adapter driver file is 7.0.26.0, you must update it.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:2/3/2004
Keywords:kbprb KB834481 kbAudEndUser kbAudITPRO