A Live Communications Server user's presence information does not appear correctly in a Web Part (834471)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003
  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Windows SharePoint Services

SYMPTOMS

After you add a Microsoft Office Live Communications Server 2003 user's e-mail address to a Web Part in a Microsoft Windows SharePoint Services-based Web site, that user's presence information does not appear correctly in that Web Part.

Note This issue also occurs if you try to view that user's presence information by using Microsoft Office Outlook 2003.

CAUSE

This issue occurs if one or both of the following conditions are true:
  • The domain part of the user's Session Initiation Protocol (SIP) Uniform Resource Identifier (URI) contains uppercase letters. For example, this issue occurs if the user has an SIP URI that is similar to the following:

    sip:username@CONTOSO.COM

  • The domain part of the user's e-mail address that is in the Web Part contains uppercase letters. For example, this issue occurs if the user's e-mail address is similar to the following:

    username@CONTOSO.COM

The letters in the domain part of the SIP URI and the letters in the domain part of the e-mail address in the Web Part must be lowercase. Unless the domain parts of both items use lowercase letters, Live Communications Server cannot match them.

RESOLUTION

To resolve this issue, modify the SIP URI of the user, and then modify the user's e-mail address entry in the Windows SharePoint Services-based Web site to use lowercase letters only. To modify the SIP URI, follow these steps:
  1. Start the Live Communications Server tool.
  2. Expand Servers, expand the home server that contains the user whose SIP URI you want to modify, and then click Users.
  3. In the right pane, double-click the user whose SIP URI you want to modify.
  4. In the SIP URI box, modify the domain part of the URI to use lowercase letters.
  5. Click Apply, and then click OK.

MORE INFORMATION

The following table shows the results of attempts to obtain presence information when you use different combinations of uppercase letters and lowercase letters in the domain part of the SIP URI and in Active Directory directory service:
AddBuddyEx URI Actual URI in Active DirectoryResult
LowercaseUppercaseSuccessful
UppercaseUppercaseUnsuccessful
UppercaseLowercaseUnsuccessful
LowercaseLowercaseSuccessful
Note For Outlook 2003, the AddBuddyEx URI is the e-mail address that the e-mail comes from. For example, the sender's e-mail address is the AddBuddyEx URI.

Modification Type:MajorLast Reviewed:2/24/2004
Keywords:kbprb KB834471 kbAudITPRO