"Stop 0x0000008E" error message in Win32k.sys when you use the keyboard to access a program menu in Windows XP (834450)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

On your Microsoft Windows XP-based computer, you receive a Stop error message that is similar to the following:
STOP 0x0000008E
The Stop error occurs in the Win32k.sys driver. You may receive the Stop error when you use the keyboard to activate and control the menu items of some programs.

CAUSE

This problem may occur when you run a program that dynamically creates and deletes menu items within a loop. If you use the keyboard to control the program menu, you may trigger a race condition in the menu handler of the Win32k.sys driver during the MNOpenHierarchy function call.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   08-Jan-2004  19:06  5.1.2600.1330   1,678,080  Win32k.sys   x86

   08-Jan-2004  19:07  5.1.2600.1330   5,623,552  Win32k.sys   IA-64
Note Because of file dependencies, this hotfix requires Windows XP Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kberrmsg kbWinXPpreSP2fix kbfix kbbug KB834450 kbAudEndUser