"Cannot create log file" error message when you start Age of Mythology (834429)



The information in this article applies to:

  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: Gold Edition

SUMMARY

The "Cannot create log file" error message may be caused by video card issues or by a corrupted profile. To resolve this problem, you have to verify that there is sufficient memory in the video card, verify that hardware acceleration of the video card is enabled, and update the video card driver. Additionally, to resolve this problem, you can to create a new user profile and verify that there is sufficient space on the hard disk.

SYMPTOMS

When you start Microsoft Age of Mythology, you may receive an error message that is similar to the following:
Cannot create log file. Please make sure you have full rights on the directory you installed Age of Mythology into, and that you have available disk space. Error: the system cannot find the path specified.

CAUSE

This problem may occur if any one of the following conditions is true:
  • Your computer does not meet the game requirements.
  • The video card hardware acceleration is set to none.
  • The user profile is corrupted.
  • The video card drivers are outdated.
  • There is not sufficient space on the hard disk to create the log file.

RESOLUTION

To resolve this problem, use the following methods in the order that they appear.

Method 1: Verify that your hardware meets the game requirements

Verify that your video card meets the game requirements. Age of Mythology requires 16 megabytes (MB) of RAM. Use the DirectX Diagnostic Tool to determine how much video memory is available. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type dxdiag, and then click OK.
  3. On the Display tab, note how much video memory is on the Approx. Total Memory line.
  4. Click Exit.
If your computer video adapter has less than 16 MB of video memory, install additional video memory on your video adapter or install a video adapter that has more video memory. Contact your computer manufacturer or video card manufacturer to install or to configure your new video card adapter. For additional information about how to contact your computer manufacturer or your video card manufacturer, see the "More Information" section of this article. If your computer meets the game requirements, go to the next method.

Method 2: Increase hardware acceleration

Increase hardware acceleration in Display Properties to Full. To do this, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, and then click Control Panel.
  2. Click Appearance and Themes, and then click Display.
  3. On the Properties tab or on the Settings tab, click Advanced, and then click Troubleshoot.
  4. Move the Hardware acceleration slider to the right to Full.
  5. Click OK two times.
  6. Start Age of Mythology.
If the problem continues to occur, go to the next method.

Method 3: Create a new administrator user account

Note This is for Microsoft Windows XP only.

Depending on your version of Windows XP, use the appropriate steps.

Microsoft Windows XP Home Edition
  1. Click Start, and then click Control Panel.
  2. Click User Accounts.
  3. In the Pick a task list box, click Create a new account.
  4. Type the name that you want to use for the account, and then click Next.
  5. Select the account type that you want, and then click Create Account.

    Note Age of Mythology requires a user account with administrator account type to run.
  6. Log off, and then sign in as the new user.
  7. Start Age of Mythology.
Microsoft Windows XP Professional
  1. Click Start, and then click Control Panel.
  2. Click User Accounts.
  3. On the Users tab, click Add.
  4. Type a name for your user account, your full name, and a description for your account.
  5. If your computer is set up as part of a client/server network, type the domain name, and then click Next.

    Note If your computer is set up as an individual computer (without a network) or in a peer-to-peer network, you do not have to provide a domain name.
  6. Type a user password, and then type the user password again to confirm it.

    Important Passwords are case sensitive. For example, MyPassword and mypassword are treated as two different passwords.
  7. Click Next.
  8. Select the level of access for your user account, and then click Finish.

    Note Age of Mythology requires a user account with administrator account type to run.
  9. Log off, and then sign in as the new user.
  10. Start Age of Mythology.
If the issue continues to occur, go to the next method.

Method 4: Update your video drivers

Contact the manufacturer of your video adapter for information about how to obtain and install the latest version of the video driver for your video adapter. For additional information about how to contact your video card manufacturer, see the "More Information" section of this article.

To see if video driver updates are available, visit the following Microsoft Windows Update Web site:

Method 5: Verify available disk space

To do this, follow these steps:
  1. On the desktop, double-click My Computer.
  2. Right-click the hard disk drive where Age of Mythology is installed, and then click Properties.
  3. Verify that the free space that is listed is more than 10 MB.
  4. If there is not sufficient free space, click Disk Cleanup.

MORE INFORMATION

For information about how to contact your video card manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:6/17/2005
Keywords:kbsetup kberrmsg kbprb KB834429 kbAudEndUser