CPU usage by the Exchange System Attendant service on offline address list servers in a hosting environment increases to 50 percent (834315)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In a hosting environment where Microsoft Exchange Server 2003 computers are configured as offline address list servers, you may find that CPU usage by the Microsoft Exchange System Attendant service (Mad.exe) on each of the servers increases to 50 percent. You experience these symptoms even after you restart each server.

For example, you may experience these symptoms in a hosting environment where you have 10,000 offline address lists and 10 Exchange Server 2003 computers that are configured as offline address list servers.

CAUSE

This problem occurs in hosting environments where Exchange Server 2003 computers are configured as dedicated offline address list servers. This problem occurs in this type of hosting environment when the update schedule for offline address lists is set to Never run. The Microsoft Exchange System Attendant service uses an OABScan task to scan offline address lists that are generated on the server. This task is scheduled to run every 13 minutes and may increase CPU usage in the Microsoft Exchange System Attendant service to 50 percent. In a hosting environment that has this configuration, the OABScan task is not required.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest updates and service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Component: Exchange System Attendant

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

  Date         Time   Version       Size       File name
  ------------------------------------------------------
  20-Dec-2003  04:35  6.5.6980.58   8,765,440  Mad.exe 

Note Because of file dependencies, this hotfix requires Exchange Server 2003.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 1.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you apply the hotfix that is described in this article, you must edit the registry to activate the hotfix and to turn off the OABScan task. To do so, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type DisableOABScanTask, and then press ENTER.
  6. Right-click the DisableOABScanTask registry value that you created in step 5, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.
Note When you set the DisableOABScanTask registry value to 1, you turn off the OABScan task. If you want to turn on the OABScan task, set the DisableOABScanTask registry value to 0 (zero) or remove the DisableOABScanTask registry value. After you do so, the following event is logged in the application event log to notify you that the task started: Type: Information
Source: MSEXchangeSA
Category: General
Event ID: 9008
Description:

Microsoft Exchange System Attendant is starting 'Oabgen.dll'.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbExchange2003sp1fix kbExchange2003preSP1fix kbfix kbbug KB834315 kbAudITPRO