A drive is represented by a "?" character in Windows Explorer when you remove a removable storage drive or disconnect a network drive on a Windows XP-based computer (834241)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

After you remove a removable storage drive or disconnect a network drive on a Microsoft Windows XP-based computer, the drive may be represented by a "?" character in Windows Explorer.

CAUSE

This issue may occur in the following scenario:
  1. You open Windows Explorer in Folders view.

    In the Windows Explorer folder list, a removable storage drive or a network drive is followed immediately by an empty CD-ROM or DVD-ROM drive.
  2. After you remove the removable storage drive from the computer, or after you disconnect the network drive by using the net use :x /delete command, the focus moves to the empty CD-ROM or DVD-ROM drive. Additionally, you receive the following message: Please insert DISK to x: drive
  3. After you click Cancel in response to this message, the focus moves to the storage drive that you removed or to the network drive that you disconnected, and the drive is represented by a "?" character.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   20-Jan-2004  18:08  6.0.2800.1334   8,241,664  Shell32.dll      x86 
   20-Jan-2004  18:08  5.1.2600.1331     680,448  Sxs.dll          x86 
   19-Jan-2004  23:08  5.1.2600.1333     586,752  Xpsp2res.dll     x86 
   20-Jan-2004  18:08  6.0.2800.1331     921,600  Comctl32.dll     x86 
   20-Jan-2004  21:13                      1,812  Controls.man     x86
   20-Jan-2004  21:13                        621  Comctl.man       x86
   20-Jan-2004  17:52  6.0.2800.1334  14,372,864  Shell32.dll      IA-64
   20-Jan-2004  17:52  5.1.2600.1331   2,030,592  Sxs.dll          IA-64
   19-Jan-2004  23:08  5.1.2600.1333     586,240  Xpsp2res.dll     IA-64
   10-Jan-2004  11:54  6.0.2800.1331   2,639,872  Comctl32.dll     IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbui kbQFE kbWinXPpreSP2fix kbfix kbbug KB834241 kbAudITPRO