When you rename your My Documents folder, the folder returns to its original name when you use your network user account to log on (834239)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003

SYMPTOMS

When you use your network user account to log on, and you have changed the name of your My Documents folder, the folder name returns to My Documents.

CAUSE

This problem occurs because Microsoft Windows XP automatically reloads the default registry settings for the computer desktop when Windows XP loads a network user profile. This action overrides any settings that you have made to the desktop for your network user account. This behavior exists to make migration from Microsoft Windows NT 4.0 to Windows XP easier. Windows NT 4.0 registry settings for the computer desktop do not contain user information. When these settings are deleted, it does not affect your user settings.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Jan-2004  19:39  5.1.2600.1336     669,696  Userenv.dll      

Windows XP, 64-Bit Edition

   Date         Time   Version            Size    File name     Platform
   ---------------------------------------------------------------------
   26-Jan-2004  19:33  5.1.2600.1336   1,713,664  Userenv.dll   IA-64
   26-Jan-2004  19:39  5.1.2600.1336     669,696  Wuserenv.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB834239 kbAudITPRO