A deadlock occurs when a program that uses WMI calls the LoadLibrary() or the FreeLibrary() function in Windows 2000 (834010)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Assume that a Microsoft ASP.NET program or a program that uses a Windows Management Instrumentation (WMI) provider makes direct or indirect calls to the LoadLibrary function or to the FreeLibrary function to load a DLL. Then, the DLL calls the RegisterTraceGuids or the UnRegisterTraceGuids function in the DllMain export function. In this scenario, a deadlock may occur in the ASP.NET program or in the program that uses a WMI provider.

For example, Microsoft Internet Explorer, Control Panel, and the Add/Remove Programs tool may stop responding (hang) after you install Microsoft Windows 2000 Service Pack 3 (SP3) or Service Pack 4 (SP4). When you stop the Remote Registry service, this permits the programs that have stopped responding to resume. This issue may occur in environments where a remote performance monitoring solution, such as PerfMan or SiteScope, is installed.

Also, when this issue occurs, Microsoft Visual Basic scripts may not run correctly, and you receive no error message. Additionally, the Task Scheduler tool may not run.

CAUSE

This problem may occur after you apply the hotfix that is described in the following article in the Microsoft Knowledge Base:

812714 Users cannot remotely monitor disk counters if they are not logged on as administrators

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   06-Feb-2004  22:28  5.0.2195.6862      73,488  Wmicore.dll      

WORKAROUND

To work around this problem, stop the Remote Registry service, and then start Internet Explorer or Control Panel. To stop the Remote Registry service, follow these steps:
  1. Right-click My Computer, and then click Manage
  2. Under Computer Management, expand Services and Applications, and then click Services.
  3. In the Services pane, click Remote Registry, and then click Stop .

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWin2000preSP5fix kbprb kbfix kbbug KB834010 kbAudITPRO