The Computer Migration Wizard that runs in Windows Server 2003 stops responding when you select many computers (833991)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

When you select many computer objects in the Computer Migration Wizard of the Active Directory Migration Tool version 2.0, you may experience both the following symptoms:
  • The Computer Migration Wizard stops responding.
  • The Next button in the Computer Migration Wizard becomes unavailable and appears dimmed.

CAUSE

This problem occurs because of memory corruption that may occur when you close the Object Picker tool in the Computer Migration Wizard.

When the NetApiBufferFree function removes the structure that contains the list of computers that you select in the Computer Migration Wizard, the NetApiBufferFree function is passed an address pointer instead of the value of that address pointer. If the value passed is not an 8-bit aligned value, the NetApiBufferFree function determines that the value is not a valid pointer value, and then returns an error result. In this case, the call fails and a small memory leak occurs. However, sometimes the NetApiBufferFree function is passed an 8-bit aligned value. In this scenario, a random memory location is freed. When this behavior occurs, you may experience the problem that is described in the "Symptoms" section of this article.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jan-2004  00:14  5.2.3790.122      844,800  Wizards.dll    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB833991 kbAudITPRO