Remote Administrators cannot browse collections, packages, or other nodes when connected to a Windows NT 4.0-based SMS 2.0 site server that has been upgraded to SMS 2.0 Service Pack 5 (833889)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

When you install Active Directory client extensions on a Microsoft Windows NT 4.0-based Systems Management Server (SMS) 2.0 site server computer that has been upgraded to SMS 2.0 Service Pack 5, remote SMS administrators can use the SMS Administrator console to connect to the site database. However, the SMS administrators cannot expand and browse collections, packages, or any other nodes in the SMS administrator console.

CAUSE

This problem occurs because of a change that was implemented in SMS 2.0 Service Pack 5 to support Microsoft Windows Server 2003 users. With this change, an external provider calls the GetUserNameEx function. Previously, the user name that was passed in by Windows Management Instrumentation (WMI) called the function. This change was necessary because the user name format that is used by WMI in Windows Server 2003 is in DNS format. SMS expects the domain\user format. However, on a Windows NT 4.0-based computer that has Active Directory client extensions installed, this change may cause the GetUserNameEx function to return an empty string for the user name.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Feb-2003  21:50  2.0.1493.5180     290,784  Extnprov.dll     
   06-Aug-2000  09:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  10:05  2.0.1493.5011     855,312  Preinst.exe      
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates



Note The following log entry in the Smsprov.log file on a Windows NT 4.0-based computer is expected and does not indicate a problem:
Error: Failed to LoadLibrary secur32.dll, error = 126. Using the user name passed from WMI

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200SP6fix kbfix kbbug KB833889 kbAudITPRO