The Advertised Programs Manager processes the wrong status MIF file on a Systems Management Server 2.0 client (833773)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

The Advertised Programs Manager (SMSAPM32.exe) on a Microsoft Systems Management Server (SMS) 2.0 client, might process the wrong status Management Information Format (MIF) file for a package after the client computer restarts. These symptoms occur only for packages where either SMS restarts computer or Program restarts computer is turned on in the program properties.

CAUSE

This problem may occur when one of the following conditions is true:
  • You turn on Use package properties for status MIF matching in the package properties, and you fill in only the Name text box on the General tab of the package properties. In this scenario, all status MIF files in the \Windows\temp folder are processed. The product name is not included in the complete file for MIF matching, although the product name is known.
  • You turn on Use package properties for status MIF matching in the package properties, and you fill in both the Name and the Version text boxes on the General tab of the package properties. In this scenario, all status MIF files in the \Windows\temp folder are processed. Only the version information appears in the ProductID section of the complete file.
  • You turn on Use these fields for status MIF matching in the package properties, and you fill in only the MIF file name text box. In this scenario, all status MIF files are processed.
  • You turn on Use these fields for status MIF matching in the package properties, and you fill in the MIF file name and the Name text boxes. In this scenario, the product name appears in the ProductID section of the complete file. However, no file name is listed.
  • You turn on Use these fields for status MIF matching in the package properties, and you fill in all the text boxes. In this scenario, name, company, and version information is included in the status MIF file. The MIF file name is not included in the ProductID section of the complete file.
Note If you change the MIF matching properties after the program has run on a client, the properties are not updated on the client.

Before the advertisement runs on a client, a different program may create a MIF file in a temporary folder. If an SMS 2.0 advertisement installs a program that restarts the computer and writes a status MIF file, the Advertised Programs Manager processes the status MIF file before the computer is restarted. After the computer restarts, the Advertised Programs Manager scans the client computer to collect any remaining MIF files, including any MIF files that were present before the SMS 2.0 advertisement ran. All remaining MIF files are processed, including MIF files that are not related to the SMS 2.0 advertisement.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2.0 Service Pack 5 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Feb-2003  12:35  2.0.1493.5140     238,944  Abnwcli.dll      
   25-Feb-2003  18:45  2.0.92.10         383,678  Apasetup.exe     
   25-Feb-2003  12:35  2.0.1493.5140     263,008  Bindclin.dll     
   25-Feb-2003  18:55  2.0.92.10       1,377,880  Ccmcore.exe      
   25-Feb-2003  18:55  2.0.1493.5183   1,251,744  Clibase.dll      
   25-Feb-2003  18:55  2.0.1493.5183   3,498,148  Clicore.exe      
   25-Feb-2003  12:55  2.0.1493.5144      90,480  Clisvcl.exe      
   25-Feb-2003  18:55  2.0.1493.5183       8,512  Cliver.exe       
   25-Feb-2003  18:55                         67  Compverbase.ini
   25-Feb-2003  18:55                         67  Compversmsapm32.ini
   25-Feb-2003  18:55                         67  Compverswdist.ini
   25-Feb-2003  12:15  2.0.1493.5136      35,168  Cqmgr32.dll      
   25-Feb-2003  12:35  2.0.1493.5140     161,120  Falclin.dll      
   25-Feb-2003  12:35  2.0.1493.5140     340,832  Mslmclin.dll     
   25-Feb-2003  12:35  2.0.1493.5140     272,736  Ndsclin.dll      
   25-Feb-2003  19:10  2.0.1493.5186      13,168  Ntlg_rem.exe     
   25-Feb-2003  19:10  2.0.1493.5186     195,440  Nt_logon.dll     
   25-Feb-2003  13:10  2.0.1493.5147      54,640  Odpsys32.exe     
   25-Feb-2003  13:10  2.0.1493.5147      60,784  Odpusr32.exe     
   25-Feb-2003  18:45  2.0.1493.5181     258,928  Smsapm32.exe     
   25-Feb-2003  13:10  2.0.92.10         641,211  Swdist32.exe 

Installation information

To apply this hotfix, follow these steps:
  1. Create a folder in a location that your SMS site servers can access.
  2. Copy the SMS2.0-SP5-KB833773.X86-ENU.exe update file to the new folder.
  3. On each SMS primary and secondary site server in your environment, log on as an administrator.
  4. Quit the SMS Administrator Console if it is running.
  5. Run the SMS2.0-SP5-KB833773.X86-ENU.exe file, and then follow the instructions in the installation wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem when you create a new package, follow these steps:
  1. If you turn on Use package properties for status MIF matching in the package properties, you must fill out the following text boxes on the General tab:
    • Name: The "Product" in the status MIF file.
    • Version: The "Version" in the status MIF file.
    • Publisher: The "Manufacturer" in the status MIF file.
    Note Each of these fields must be filled out for MIF matching to operate correctly.
  2. If you turn on Use these fields for status MIF matching on the Reporting tab in the package properties, you can use any one or more of the text boxes for MIF matching except for the MIF file name text box.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbAdvertisement kbPackage kbClient kbSMS200preSP6fix kbinterop kbSoftwareDist kbfix kbBug KB833773 kbAudITPRO