You cannot print from a Terminal Server session that is hosted by Windows Server 2003 (833746)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to print from a Terminal Server session to a redirected network printer, the print job does not print, although the print queue in the session shows the print status as Printing.

CAUSE

This problem occurs when all the following conditions are true:
  • The Terminal Services client computer is running Microsoft Windows XP or Microsoft Windows 2000.
  • The network printer is mapped to the LPT1 port or to any other parallel port on the client computer.
  • You use the Net Use command to connect to a network share on the client computer that is running the Terminal Services session.
  • The terminal server is a computer that is running Microsoft Windows Server 2003.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Jan-2004  23:42  5.2.3790.118      188,416  Rdpdr.sys

Windows Server 2003, 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Jan-2004  23:42  5.2.3790.118      595,968  Rdpdr.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbprint kbTermServ kbBug kbfix kbQFE kbWinServ2003preSP1fix KB833746 kbAudITPRO