FIX: A signed RosettaNet message from the partner may not be processed in BizTalk Server Accelerator for RosettaNet (833646)



The information in this article applies to:

  • Microsoft BizTalk Server Accelerator for RosettaNet, version 2.0

SYMPTOMS

Microsoft BizTalk Server Accelerator for RosettaNet may not process a signed RosettaNet message from the partner. The message is moved to the BizTalk Suspend Queue and you receive the following error message in the application log:
The certificate found in the incoming document's signature does not match with the certificate specified in the channel context. This could have occured due to an error while establishing the partner relationship or because the originator was an invalid partner.

Received signature certificate: tim@companyxyz.com
Certificate specified in channel context: Contoso
Note In this error message, "occured" is a misspelling of the word "occurred."

CAUSE

This problem occurs if the signing certificate has an e-mail attribute in its Subject field such as the following:

E = tim@companyxyz.com

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next BizTalk Server Accelerator for RosettaNet 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size    File name
   --------------------------------------------------------
   19-Dec-2003  02:23  3.0.567.0  70,656  Biztalkparser.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kberrmsg kbQFE kbfix kbbug KB833646 kbAudDeveloper kbAudITPRO