The Microsoft Exchange Information Store service uses 100 percent of the CPU resources on an Exchange 2000 Server or an Exchange Server 2003 (833607)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

The Microsoft Exchange Information Store service (Store.exe) may consume 100 percent of the CPU resources on a computer that is running Microsoft Exchange 2000 Server or Exchange Server 2003.

CAUSE

This problem may occur if the information store on your Exchange server receives e-mail messages that contain deep-nested delivery status notification messages.

RESOLUTION

Exchange Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Exchange 2000 Server

To resolve this problem, obtain the August 2004 Exchange 2000 Server Post-Service Pack 3 update rollup.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
30-Jan-2004  01:50  6.0.6561.0      3,919,872  Cdoex.dll        
16-Dec-2003  01:01                     12,720  Ctrl_calendarview20.htc
16-Dec-2003  01:01                     91,631  Ctrl_calendarview20.js
30-Jan-2004  01:45  6.0.6561.0        856,064  Davex.dll        
30-Jan-2004  01:45  6.0.6561.0         53,248  Davexpc.dll      
30-Jan-2004  01:41  6.0.6561.0        131,072  Drviis.dll       
30-Jan-2004  01:42  6.0.6561.0        577,536  Dsaccess.dll     
30-Jan-2004  00:51  6.0.6561.0        184,320  Dscmsg.dll       
30-Jan-2004  00:51  6.0.6561.0        962,560  Emsmdb32.dll     
30-Jan-2004  01:44  6.0.6561.0      2,179,072  Ese.dll          
30-Jan-2004  01:44  6.0.6561.0         40,960  Eseperf.dll      
16-Dec-2003  01:06                      6,991  Eseperf.hxx
30-Jan-2004  01:44                    391,634  Eseperf.ini
30-Jan-2004  01:50  6.0.6561.0      3,575,808  Excdo.dll        
30-Jan-2004  01:41  6.0.6561.0         90,112  Eximap4.dll      
30-Jan-2004  01:42  6.0.6561.0        262,144  Exmime.dll       
30-Jan-2004  00:30  6.0.6561.0        176,128  Exnntp.dll       
30-Jan-2004  01:45  6.0.6561.0        143,360  Exodbesh.dll     
30-Jan-2004  01:45  6.0.6561.0         57,344  Exodbpc.dll      
30-Jan-2004  01:45  6.0.6561.0        200,704  Exodbprx.dll     
30-Jan-2004  01:45  6.0.6561.0      2,179,072  Exoledb.dll      
30-Jan-2004  01:39  6.0.6561.0         81,920  Exosal.dll       
30-Jan-2004  01:41  6.0.6561.0         32,768  Expop3.dll       
30-Jan-2004  01:42  6.0.6561.0         32,768  Exproto.dll      
30-Jan-2004  01:45  6.0.6561.0        307,200  Exprox.dll       
30-Jan-2004  00:55  6.0.6561.0        143,360  Exschema.exe     
30-Jan-2004  01:46  6.0.6561.0        331,776  Exsmtp.dll       
30-Jan-2004  00:57  6.0.6561.0        675,840  Exwform.dll      
30-Jan-2004  00:32  6.0.6561.0        180,224  Exwin32.dll      
30-Jan-2004  00:54  6.0.6561.0         40,960  Febecfg.dll      
30-Jan-2004  01:41  6.0.6561.0         32,768  Iisif.dll        
30-Jan-2004  01:43  6.0.6561.0        135,168  Iisproto.dll     
30-Jan-2004  01:43  6.0.6561.0         61,440  Imap4be.dll      
30-Jan-2004  00:57  6.0.6561.0        319,488  Imap4evt.dll     
30-Jan-2004  00:55  6.0.6561.0        126,976  Imap4fe.dll      
30-Jan-2004  01:41  6.0.6561.0        126,976  Imap4svc.dll     
30-Jan-2004  01:42  6.0.6561.0         40,960  Jcb.dll          
30-Jan-2004  00:31  6.0.6561.0         49,152  Mdbevent.dll     
30-Jan-2004  00:48  6.0.6561.0      2,289,664  Mdbmsg.dll       
30-Jan-2004  00:33  6.0.6561.0         32,768  Mdbrole.dll      
30-Jan-2004  00:51  6.0.6561.0        909,312  Mdbsz.dll        
30-Jan-2004  01:43  6.0.6561.0         24,576  Mdbtask.dll      
30-Jan-2004  00:30  6.0.6561.0        151,552  Nntpex.dll       
30-Jan-2004  01:38  6.0.6561.0         94,208  Peexch50.dll     
30-Jan-2004  01:39  6.0.6561.0        413,696  Phatcat.dll      
30-Jan-2004  01:41  6.0.6561.0         36,864  Pop3be.dll       
30-Jan-2004  00:57  6.0.6561.0        303,104  Pop3evt.dll      
30-Jan-2004  00:56  6.0.6561.0         24,576  Pop3fe.dll       
30-Jan-2004  01:39  6.0.6561.0         73,728  Pop3svc.dll      
30-Jan-2004  00:57  6.0.6561.0        163,840  Protomsg.dll     
30-Jan-2004  01:42  6.0.6561.0        532,480  Reapi.dll        
30-Jan-2004  01:46  6.0.6561.0        311,296  Resvc.dll        
30-Jan-2004  01:41  6.0.6561.0      4,673,536  Store.exe        
30-Jan-2004  00:57  6.0.6561.0      3,735,552  Wmtemplates.dll  

Note Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

After you apply this hotfix, you must add the LimitEmbeddingDepth registry subkey on the server to resolve the problem. To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then right-click the following registry subkey:

    HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/MSExchangeIS/ParametersSystem/InternetContent

  3. Click New, and then click DWORD Value.
  4. In the New Value #1 box, type LimitEmbeddingDepth, and then press ENTER.
  5. In the right pane, click LimitEmbeddingDepth, click Edit, and then click Modify.
  6. In the Value Data box, type an appropriate amount between 1 and 99 for your environment. Note that 100 is both the default value and the maximum value.

    Note An appropriate amount for an environment depends on the following factors:
    • Determine how many regular messages are received that are nested and how deeply nested the messages can be before there is a performance problem on the server. When a message exceeds the LimitEmbeddingDepth value, a user who receives the nested message can no longer open or move the message. This behavior occurs although the message is delivered to the user's Inbox. The user receives one of the following error messages. When this behavior occurs, the user can only delete the message from his or her Inbox.
      Can't open this item. Unknown Error.
      Can't move the items. The item could not be moved. It was either already moved or deleted, or access was denied.
    • If delivery is set to a personal folders (.pst) file, and a nested message that exceeds the LimitEmbeddingDepth value is received, the message is not transferred to the .pst file. This behavior occurs because the message exceeds the LimitEmbeddingDepth limit. The message remains stuck in the user's Inbox on the server. Then, the Outlook client frequently tries to deliver the message to the .pst file. These attempts are unsuccessful. The user can only delete the message from the Inbox on the server.
    • If the user is in Outlook 2003 cached mode, a nested message that exceeds the LimitEmbeddingDepth value cannot reach the user's local mailbox store. In this scenario, messages that are similar to the following are logged in the sync log:
      23:26:48 Error synchronizing folder
      23:26:48 [80040305-3EE-80040305-560]
      23:26:48 Unknown Error.
      23:26:48 Microsoft Exchange Server Information Store
      23:26:48 For more information on this failure, click the URL below:
      23:26:48 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-3ee-80040305-560
      Additionally, the following events may be logged in the Application event log when the server tries to open the message or tries to transfer the message: Event Type: Warning
      Event Source: MSExchangeIS
      Event Category: Content Engine
      Event ID: 9667
      Computer: Server Name
      Description: Error -2147220731 occurred while converting message 1-3448 from Internet to MAPI format. The mailbox owner is /o=Organization Name/ou=Administrative Group Name/cn=Recipients/cn=Username, and the folder is /Inbox.Event Type: Error
      Event Source: MSExchangeIS
      Event Category: Content Engine
      Event ID: 12002
      Computer: Server Name
      Description: Error 80040305-80000000 occurred while processing message <> from Username.
  7. Under Base, click Decimal, and then click OK.
  8. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Microsoft Exchange Server 2003 Service Pack 2.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbHotfixServer kbQFE kbfix kbExchange2000preSP4fix kbbug KB833607 kbAudITPRO