Users cannot access the Web console or view MOM Reporting after you install MOM 2000 Service Pack 1 (833421)



The information in this article applies to:

  • Microsoft Operations Manager 2000 SP1



Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you install Microsoft Operations Manager (MOM) 2000 Service Pack 1, you may experience one or both of the following symptoms:
  • When a member of the OnePointOp Users security group tries to access the Web console, the user may receive the following error message, where domain\account matches the member's domain name and user account:
    An error occurred while accessing the database. The most likely cause is your account not having proper access. Be sure that your account, domain\account, is a member of the "OnePointOp Users" local group on all DAS machines. Other causes include the database being unavailable.

    The actual error was: Permission denied
  • Users cannot install or view MOM Reporting on the computer where the MOM database is installed.

CAUSE

These symptoms may occur when either of the following conditions is true:
  • The OnePointOp Users group does not have full access permissions to the HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OnePoint\Databases registry subkey.
  • You have added users to the OnePointOp Reporting security group on computers where the MOM database and the MOM Data Access Server, Consolidator, and Agent Manager (DCAM) are installed. Only users who are members of the Administrators group on the MOM database computer can install or view MOM Reporting. After you complete the database installation or upgrade, the ReportViewer security role in the OnePoint database no longer has the correct permissions to view MOM Reporting.

RESOLUTION

To resolve the error message problem that is described in the "Symptoms" section of this article, follow these steps on computers where the DCAM is installed. Make sure an instance of the Dllhost.exe file is not running under the user name IWAM_local computer name. To verify that the Dllhost.exe file is not running, follow these steps:
  1. Right-click the Windows task bar, and then click Task Manager.
  2. Click Processes, and then make sure that Show processes from all users is selected.
  3. Search for an instance of the Dllhost.exe file that is running as user name IWAM_local computer name, and then click End Process, if it exists.
After you verify that the user name IWAM_local computer name does not exist, use one of the following methods to resolve the error message problem:
  • On all computers where the DCAM is installed, log on as an administrator and run the WebConsoleFix.exe file. This file is located in the \Support Tools folder on the MOM 2000 Service Pack 1 CD-ROM.
  • On all computers where the DCAM is installed, grant Full Control permissions to the OnePointOp Users group. To do this, follow these steps:

    Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    1. Click Start, and then click Run.
    2. Type regedt32 in the Open box, and then click OK.
    3. Locate the HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OnePoint\Databases registry subkey.
    4. Click the Databases subkey, click the Security menu, and then click Permissions.
    5. Grant Full Control permission to the OnePointOp Users local group.
To resolve the problem of no access to MOM Reporting, follow these steps on the computer where the MOM database is installed:
  1. On the computer where the MOM database is installed, log on as an administrator.
  2. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  3. On the File menu, click Open.
  4. Locate the \Support Tools\ folder on the MOM 2000 Service Pack 1 CD-ROM.
  5. Click ReportingFix.sql, and then click Open.
  6. On the Query menu, click Execute.
For additional information, click the following article number about to view the article about in the Microsoft Knowledge Base:

304685 Description of security rights for Microsoft Operations Manager 2000


Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbDatabase kbReport kberrmsg kbUser kbUpgrade kbSecurity kbMiscTools kbprb KB833421 kbAudITPRO