"%" character in Terminal Services profile path appears as a numeric string when you use the TSPROF command in Windows Server 2003 (833308)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

If you use an environment variable that contains a percent sign character ("%") in your Terminal Services profile path, and you run the tsprof command to display the profile path, the "%" character appears as a numeric string. For example, if you specify a Terminal Services profile path of %logonserver%\Path for your user account, and then you type tsprof /q / local YourUsername from a command prompt, the profile path appears as { 1237717237ogonserver\Path }.

CAUSE

This problem occurs in Microsoft Windows Server 2003 because the tsprof command interprets the "%" character in the Terminal Services profile path as a printf function format specifier. When the printf function encounters the "%" character in the profile path, the function converts the value of the first argument after the "%" character and outputs the results as a numeric string.

Note Format specifications always start with a percent sign.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   13-Jan-2004  18:16  5.2.3790.118       15,360  Tsprof.exe   x86
   13-Jan-2004  01:14  5.2.3790.118       35,840  Tsprof.exe   IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbTermServ kbBug kbfix kbQFE kbWinServ2003preSP1fix KB833308 kbAudITPRO