You receive a "Mqbkup error: 80 The file exists" error message when you try to restore a backup in Message Queuing (833176)



The information in this article applies to:

  • Microsoft Message Queuing 3.0

SYMPTOMS

When you try to restore a Microsoft Message Queuing backup by using the Mqbkup.exe utility, it may fail, and you receive the following error message:
Mqbkup error: 80 The file exists.

CAUSE

This problem occurs if you use the Computer Management tool to move the Message Queuing storage directories so that the transaction logs are in a private directory that is not shared or accessible by others. When you restore a backup by using the Mqbkup.exe utility, it first deletes all files from the directories, and then copies the backed up files to these empty directories. The Mqbkup.exe utility did not delete files from the directory that holds the transaction logs. Therefore, it does not copy to that directory, and you receive the error message.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Dec-2003  19:49  5.2.1723.107       28,160  Mqbkup.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New File Naming Schema for Microsoft Windows Software Update Packages


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB833176 kbAudDeveloper